Skip to Main Content
Levi, Ray & Shoup, Inc.

← Back to Search

Download PDF Version Show Related Articles
System requirements Drivve | Image Version 7, 8 and 9
Note
For system requirements of older Drivve | Image versions, please refer to the following document:
 System requirements Drivve | Image (older versions)

 

System requirements Drivve | Image Version 8.0 and 9.0

Supported operating systems: Microsoft Windows

  • Server 2019 all editions
  • Server 2016 all editions
  • Server 2012 all editions
  • Windows 8 Pro
  • Windows 8.1
  • Windows 10 Pro

 

Other components

  • Windows features being installed during setup (might require a system reboot):
    • Internet Information Services / Webserver (IIS) Role
    • Windows Identity Foundation
  • Microsoft .Net Framework 4.8 or higher
  • Available storage space: at least 1,5 GB (program data).
  • TCP/IP network protocol.
  • Internet connection (for software registration)
 Minimum requirement for RAM: 4GB
 We strongly recommend assigning a fixed IP address for the Drivve | Image server.

 

Automatic monitoring of the free harddisk memory

The free harddisk memory is monitored automatically during the scanning process: If the harddisk runs out of memory and only 1.5 GB, 1 GB oder 0.5 GB of free harddisk memory is left, Drivve | Image displays a warning and sends a notification email.

Caution: If there is only 500 MB free harddisk memory left, the Drivve | Image Service is stopped
To restart the Drivve | Image service, a minimum of 1.5 GB free harddisk memory is required.

 

Prequisite for email notification 
To notify the administrator via email, the sending of email notifications in error cases has to be configured in the Drivve | Image configuration tool (see also   How can I configure Drivve | Image to send an email in the case of an error?)

 

Supported SharePoint servers

  • Windows SharePoint Services 3.0 (WSS)
  • Microsoft Office SharePoint Server 2007/2010 MOSS Standard
  • Microsoft Office SharePoint Server 2007/2010 MOSS Enterprise
  • Microsoft SharePoint 2010
  • Microsoft SharePoint Foundation 2010
  • Microsoft SharePoint 2013 (All 2013 editions)
  • Microsoft Office 365
No additional software must be installed on the SharePoint server. Http and Https are supported.
 

Not supported servers

  • Search Server 2008 Express
  • Search Server 2008
  • Forms Server 2007
  • Microsoft Office Project Server 2007
 

Supported Email servers

  • Microsoft Exchange 2003 (using WebDav)
  • Microsoft Exchange 2007 (using WebDav or Exchange Web Services)
  • Microsoft Exchange 2010 (using Exchange Web Services)
  • Microsoft Exchange 2013 (using Exchange Web Services)
  • Microsoft Exchange 2016 (using Exchange Web Services)
  • Microsoft Office 365
  • Any SMTP compatible Email server (SSL is supported)
  • Lotus Domino (Version 4.4 and higher)
No additional software or email client (like MAPI) must be installed on the Exchange Server. Http and Https are supported. Depending on the Exchange Server version, either WebDAV or Exchange Web Services must be enabled on the Exchange Server.
 

Not supported Email servers

Novell Groupwise
 

Which devices does Drivve | Image support?

This document provides an overview of the devices (sorted by vendor) Drivve | Image supports.

 

Supported Sharp® devices

Drivve | Image supports all OSA2, OSA3, OSA4 and OSA5 Sharp® devices except for the Jupiter series and the Dragon series (the Jupiter series comprises AR-M351N/U, AR-M451 N/U; the Dragon series comprises AR-M550, AR-M620, AR-M700).

Prerequisite
To use Drivve | Image on a Sharp OSA device, the AMX2 key has to be activated on the Sharp OSA device.

 

 

Supported Canon® ScanFront® devices

Drivve | Image supports the following Canon®ScanFront® devices:

  • ScanFront® 220 / 220P
  • ScanFront® 300 / 300P
  • ScanFront® 330 (starting with Drivve | Image 7.0)
  • ScanFront ® 400 (starting with  Drivve | Image 7.0.740)

 


Supported Toshiba® devices

Drivve | Image supports all e-BRIDGE-enabled Toshiba®devices (e-BRIDGE 3 or later).

Prerequisite
Make sure that the Toshiba Embedded Web Browser (EWB) is enabled on your Toshiba® device.
The EWB is enabled through the "External Interface Enabler"(Code: GS-1020). This option is not available in all markets and you should check with your Toshiba representatives. 

 

 

Supported Xerox® devices

Drivve | Image supports all EIP enabled Xerox® devices including ColorQubeâ„¢, VersaLink® and AltaLink® models. 

 

Supported Fujitsu® devices

Drivve | Image supports the following Fujitsu® network scanners:

  • fi-6010
  • ScanSnap N1800
  • N7100

 

Note: Restrictions of N7100
The network scanner N7100 does not have a hardware keyboard.
To be able to enter data in Drivve | Image profiles at the device display, a software keyboard is shown. If the software keyboard is shown on the display, graphical elements of the profile such as input fields are misaligned. To avoid this, we recommend to use a USB keyboard.

 

 

Supported Kyocera® devices

Drivve | Image  supports all HyPAS-enabled Kyocera®devices (A3 und A4).

 

Supported Samsung® devices

Drivve | Image Samsung® supports all XOA-based Samsung® MFPs with a display size of 7", 8,9" and 10,1".

 LRS hereby announces, effective 1st March 2021 Drivve I Image Samsung edition is no longer available for purchase. No further enhancements or support will be available for Drivve | Image Samsung Edition. This product will no longer be maintained after the current maintenance and support term ends for customers / end customers.


 

Supported OKI® devices

Drivve | Image supports all OKI® devices

  • of the series MC700 and ES94/91xx
  • using the sXP platform

 

In addition, the following OKI® devices are supported:

  • MC873 / MC853, ES8473 / ES8453 
    (A3 color MFP series of sXP2)
  • MB562 / MB492, ES5162 / ES4192 
    ( A4 mono MFP series of sXP2 )

Note
To upgrade to the latest firmware for the devices listed above, use the following link:
http://global.okiprintingsolutions.com/FWInterface.nsf/frmSelectLanguage

 

Caution
If you are using OKI DIN A3 MFPs, documents may only scanned via landscape feed.

 


Supported Lexmark® devices

Note
Lexmark® devices are supported starting with Drivve |Image version 6.1.

 

Drivve | Image supports all Lexmark® devices supporting Flash. These are all devices with Framework 3.x and 4.x.
Drivve | Image supports all Lexmark® devices supporting Android. These are all devices with Framework 5.x and 6.x.

Caution
The following overview of the supported Lexmark® devices is subject to change and exemplary. 
To determine the actual supported eSF version for a certain device,  follow the 
http://support.lexmark.com/index?page=content&id=HO3859&locale=EN&userlocale=EN_US reference provided by Lexmark.


Lexmark® devices with Framework 3.x
X746de, X748de, X748dte, XS748, C748, CS748, X792de, X792dte, XS795, XS796, XS796, XS798, C792e, C792de, C792dte, C792dhe, CS796, X925de, XS925, C925de, X950de, X952de, X952dte, X954de, X954dhe, XS950, XS955, C950de, X548dte, XS548, 6500e

Lexmark® devices with Framework 4.x
MS610de, MS610dte, M3150, MS810de, M5155, M5163, MS812de, M5170, MS911de, M9155, CS510de, CS510dte, CS511,C2132,MX410Series, MX51x, XM1145, MX610 Series, MX611 Series, XM3150, MX710 Series, XM5163, MX711 Series, XM5170, MX810 Series, XM7155, XM7155X, XM7163, XM7163X, XM7170, XM7170X, MX910de, MX911dte, MX912dxe, XM9145, XM9155, XM9165, CX410 Series, CX510 Series, XC2132, MX6500e Series

 

Lexmark® devices with Framework 5.x/6.x (Android based)
e.g. CX725 series, CX820 series, CX825 series, CX860 series
 

Supported Konica Minolta® devices

Note
Konica Minolta® devices are supported starting with Drivve | Image Version 7.0.500.

 

  Drivve | Image for Konica Minolta® is not supported in the Americas.

Drivve | Image supports all browser-enabled Konica Minolta®devices. However, there are also Konica Minolta® devices not browser-enabled that can be fitted with a browser.

For further information see  How do I install Drivve | Image on a Konica Minolta device?

 

Supported Develop® devices

The support for Develop devices corresponds to the support for Konica Minolta devices. 

 

Supported Ricoh® devices

Note 
Ricoh® devices are supported starting with Drivve | Image Version 8.2

 

Drivve | Image supports all SOP-enabled Ricoh® devices. If a device does not feature a Ricoh®  Smart Operation Panel, please check if there is an optional upgrade available for your model, so the Ricoh SmartSDK, successor of SDK Type-J(SDK/J), the Web API and the WebBrowserNX can be made available for the seamless integration of Drivve | Image.

For further information see  How do I manually register Drivve | Image on a Ricoh device? (Ricoh Edition)

 

 

Supported HP® devices

Note 
HP® devices are supported starting with Drivve | Image version 8.4

 

Drivve | Image supports HP MFPs which support OXPd.NET (Open Extensibility Platform device layer) enabled devices and provide the WebKit based browser.
(Indication that your device does provide those features is OXPd JavaScript support according to
https://d1dt3lk9ptjcdc.cloudfront.net/documentation/hp_device_compatibility_guide.pdf 
and a FurureSmart family firmware)

Further requirement is a control panel that sports a resolution of either 800 x 6001024 x 600 (will use 800x600) or 1024 x 800 pixels.

The current internal HP display series that fulfill those requirements are Oriani, Phantom, Pharos, PhotonR and Pulsar. (For all those control panels the versions with and without Pull-Out keyboard are supported).

 

Note

According to recent (2019-03-21) HP information, only >= 8"panels are currently supporting the required resolutions. 

 

Installation method

For HP devices automatic installation via device management is supported.

 

Network Communication

The following ports are used by default for the communication between Drivve | Image and the device

TCP 80, 9000 (http)

TCP 443, 4443 (https)

TCP 7627 (OXPd)

UDP 161 (SNMP)

TCP 9100 (direct print)

System requirements Drivve | Image Version 7.0

Supported operating systems: Microsoft Windows

  • Server 2016 all editions
  • Server 2008 all editions, 32 and 64 bit
  • Server 2012 all editions, 32 and 64 bit
  • Small Business Server 2008, 2011
    Due to performance interference we do not recommend to install Drivve | Image on Small Business Server!
  • Windows 7, 32 and 64 bit, all editions except Home Edition
  • Windows 8 Pro
  • Windows 8.1
  • Windows 10 Pro

 

Other components

  • Internet Information Server with enabled WWW services.
  • Microsoft .NET 3.5 Framework SP1
  • Microsoft .NET 4 Framework  latest version is recommended, minimum version required: 4.5.1
  • Available storage space: at least 1 GB (program data).
  • TCP/IP network protocol.
  • Internet connection (for software registration)
 Minimum requirement for RAM: 4GB

 

Automatic monitoring of the free harddisk memory

The free harddisk memory is monitored automatically during the scanning process: If the harddisk runs out of memory and only 1.5 GB, 1 GB oder 0.5 GB of free harddisk memory is left, Drivve | Image displays a warning and sends a notification email.

Caution: If there is only 500 MB free harddisk memory left, the Drivve | Image Service is stopped
To restart the Drivve | Image service, a minimum of 1.5 GB free harddisk memory is required.

 

Prequisite for email notification 
To notify the administrator via email, the sending of email notifications in error cases has to be configured in the Drivve | Image configuration tool (see also   How can I configure Drivve | Image to send an email in the case of an error?)

 

Supported SharePoint servers

  • Windows SharePoint Services 3.0 (WSS)
  • Microsoft Office SharePoint Server 2007/2010 MOSS Standard
  • Microsoft Office SharePoint Server 2007/2010 MOSS Enterprise
  • Microsoft SharePoint 2010
  • Microsoft SharePoint Foundation 2010
  • Microsoft SharePoint 2013 (All 2013 editions)
  • Microsoft Office 365
No additional software must be installed on the SharePoint server. Http and Https are supported.
 

Not supported servers

  • Search Server 2008 Express
  • Search Server 2008
  • Forms Server 2007
  • Microsoft Office Project Server 2007
 

Supported Email servers

  • Microsoft Exchange 2003 (using WebDav)
  • Microsoft Exchange 2007 (using WebDav or Exchange Web Services)
  • Microsoft Exchange 2010 (using Exchange Web Services)
  • Microsoft Exchange 2013 (using Exchange Web Services)
  • Microsoft Office 365
  • Microsoft Exchange 2013
  • Any SMTP compatible Email server (SSL is supported)
  • Lotus Domino (Version 4.4 and higher)
No additional software or email client (like MAPI) must be installed on the Exchange Server. Http and Https are supported. Depending on the Exchange Server version, either WebDAV or Exchange Web Services must be enabled on the Exchange Server.
 

Not supported Email servers

Novell Groupwise
 

Which devices does Drivve | Image support?

This document provides an overview of the devices (sorted by vendor) Drivve | Image supports.

 

Supported Sharp® devices

Drivve | Image supports all OSA2, OSA3, OSA4 and OSA5 Sharp® devices except for the Jupiter series and the Dragon series (the Jupiter series comprises AR-M351N/U, AR-M451 N/U; the Dragon series comprises AR-M550, AR-M620, AR-M700).

Prerequisite
To use Drivve | Image on a Sharp OSA device, the AMX2 key has to be activated on the Sharp OSA device.

 

 

Supported Canon® ScanFront® devices

Drivve | Image supports the following Canon®ScanFront® devices:

  • ScanFront® 220 / 220P
  • ScanFront® 300 / 300P
  • ScanFront® 330 (starting with Drivve | Image 7.0)
  • ScanFront ® 400 (starting with  Drivve | Image 7.0.740)

 


Supported Toshiba® devices

Drivve | Image supports all e-BRIDGE-enabled Toshiba®devices (e-BRIDGE 3 or later).

Prerequisite
Make sure that the Toshiba Embedded Web Browser (EWB) is enabled on your Toshiba® device.
The EWB is enabled through the "External Interface Enabler"(Code: GS-1020). This option is not available in all markets and you should check with your Toshiba representatives. 

 

 

Supported Xerox® devices

Drivve | Image supports all EIP enabled Xerox® devices including ColorQubeâ„¢, VersaLink® and AltaLink® models. 

 

Supported Fujitsu® devices

Drivve | Image supports the following Fujitsu® network scanners:

  • fi-6010
  • ScanSnap N1800
  • N7100

 

Note: Restrictions of N7100
The network scanner N7100 does not have a hardware keyboard.
To be able to enter data in Drivve | Image profiles at the device display, a software keyboard is shown. If the software keyboard is shown on the display, graphical elements of the profile such as input fields are misaligned. To avoid this, we recommend to use a USB keyboard.

 

 

Supported Kyocera® devices

Drivve | Image  supports all HyPAS-enabled Kyocera®devices (A3 und A4).

 

Supported Samsung® devices

Drivve | Image Samsung® supports all XOA-based Samsung® MFPs with a display size of 7", 8,9" and 10,1".

 LRS hereby announces, effective 1st March 2021 Drivve I Image Samsung edition is no longer available for purchase. No further enhancements or support will be available for Drivve | Image Samsung Edition. This product will no longer be maintained after the current maintenance and support term ends for customers / end customers.


 

Supported OKI® devices

Drivve | Image supports all OKI® devices

  • of the series MC700 and ES94/91xx
  • using the sXP platform

 

In addition, the following OKI® devices are supported:

  • MC873 / MC853, ES8473 / ES8453 
    (A3 color MFP series of sXP2)
  • MB562 / MB492, ES5162 / ES4192 
    ( A4 mono MFP series of sXP2 )

Note
To upgrade to the latest firmware for the devices listed above, use the following link:
http://global.okiprintingsolutions.com/FWInterface.nsf/frmSelectLanguage

 

Caution
If you are using OKI DIN A3 MFPs, documents may only scanned via landscape feed.

 


Supported Lexmark® devices

Note
Lexmark® devices are supported starting with Drivve |Image version 6.1.

 

Drivve | Image supports all Lexmark® devices supporting Flash. These are all devices with Framework 3.x and 4.x.
Drivve | Image supports all Lexmark® devices supporting Android. These are all devices with Framework 5.x and 6.x.

Caution
The following overview of the supported Lexmark® devices is subject to change and exemplary. 
To determine the actual supported eSF version for a certain device,  follow the 
http://support.lexmark.com/index?page=content&id=HO3859&locale=EN&userlocale=EN_US reference provided by Lexmark.


Lexmark® devices with Framework 3.x
X746de, X748de, X748dte, XS748, C748, CS748, X792de, X792dte, XS795, XS796, XS796, XS798, C792e, C792de, C792dte, C792dhe, CS796, X925de, XS925, C925de, X950de, X952de, X952dte, X954de, X954dhe, XS950, XS955, C950de, X548dte, XS548, 6500e

Lexmark® devices with Framework 4.x
MS610de, MS610dte, M3150, MS810de, M5155, M5163, MS812de, M5170, MS911de, M9155, CS510de, CS510dte, CS511,C2132,MX410Series, MX51x, XM1145, MX610 Series, MX611 Series, XM3150, MX710 Series, XM5163, MX711 Series, XM5170, MX810 Series, XM7155, XM7155X, XM7163, XM7163X, XM7170, XM7170X, MX910de, MX911dte, MX912dxe, XM9145, XM9155, XM9165, CX410 Series, CX510 Series, XC2132, MX6500e Series

 

Lexmark® devices with Framework 5.x/6.x (Android based)
e.g. CX725 series, CX820 series, CX825 series, CX860 series
 

Supported Konica Minolta® devices

Note
Konica Minolta® devices are supported starting with Drivve | Image Version 7.0.500.

 

  Drivve | Image for Konica Minolta® is not supported in the Americas.

Drivve | Image supports all browser-enabled Konica Minolta®devices. However, there are also Konica Minolta® devices not browser-enabled that can be fitted with a browser.

For further information see  How do I install Drivve | Image on a Konica Minolta device?

 

Supported Develop® devices

The support for Develop devices corresponds to the support for Konica Minolta devices. 

 

Supported Ricoh® devices

Note 
Ricoh® devices are supported starting with Drivve | Image Version 8.2

 

Drivve | Image supports all SOP-enabled Ricoh® devices. If a device does not feature a Ricoh®  Smart Operation Panel, please check if there is an optional upgrade available for your model, so the Ricoh SmartSDK, successor of SDK Type-J(SDK/J), the Web API and the WebBrowserNX can be made available for the seamless integration of Drivve | Image.

For further information see  How do I manually register Drivve | Image on a Ricoh device? (Ricoh Edition)

 

 

Supported HP® devices

Note 
HP® devices are supported starting with Drivve | Image version 8.4

 

Drivve | Image supports HP MFPs which support OXPd.NET (Open Extensibility Platform device layer) enabled devices and provide the WebKit based browser.
(Indication that your device does provide those features is OXPd JavaScript support according to
https://d1dt3lk9ptjcdc.cloudfront.net/documentation/hp_device_compatibility_guide.pdf 
and a FurureSmart family firmware)

Further requirement is a control panel that sports a resolution of either 800 x 6001024 x 600 (will use 800x600) or 1024 x 800 pixels.

The current internal HP display series that fulfill those requirements are Oriani, Phantom, Pharos, PhotonR and Pulsar. (For all those control panels the versions with and without Pull-Out keyboard are supported).

 

Note

According to recent (2019-03-21) HP information, only >= 8"panels are currently supporting the required resolutions. 

 

Installation method

For HP devices automatic installation via device management is supported.

 

Network Communication

The following ports are used by default for the communication between Drivve | Image and the device

TCP 80, 9000 (http)

TCP 443, 4443 (https)

TCP 7627 (OXPd)

UDP 161 (SNMP)

TCP 9100 (direct print)